europa 2.0 last firmware needed

Discussions concerning the Europa mod for the Roland Jupiter-6 analogue synthesizer
dir_marillion
Posts: 5
Joined: Mon Sep 23, 2013 6:39 pm

europa 2.0 last firmware needed

Postby dir_marillion » Thu Oct 03, 2013 6:04 pm

Hi there,
Can anyone send me the latest release of Europa 2.0 firmware ?
I have emailed the author, a long time ago, but not any respond...

Thank you very much

dir_marillion
Posts: 5
Joined: Mon Sep 23, 2013 6:39 pm

Postby dir_marillion » Tue Oct 22, 2013 5:10 pm

Jeffrey from Synthcom sent me the latest firmware, I upgraded my Jup and everything is working perfect.

Thread can be closed now.
Thank you very much.

The LT
Posts: 10
Joined: Thu Jan 16, 2014 4:54 pm

Re: europa 2.0 last firmware needed

Postby The LT » Thu May 08, 2014 7:02 pm

Can you share the firmware? I am trying to contact Jeffrey for months now with no avail.

User avatar
Fuseball
Posts: 6
Joined: Sun Dec 08, 2013 11:24 pm

Re: europa 2.0 last firmware needed

Postby Fuseball » Tue May 13, 2014 11:53 am

The LT wrote:Can you share the firmware? I am trying to contact Jeffrey for months now with no avail.

When I bought a Europa from him, in November 2013, he said he was going to be on indefinite hiatus for a few months. I guess he's still not yet back online.

Unfortunately I don't have the firmware image for 2.0. The Europa I bought already had the latest version on it.
Some noises - Bright Pylon

The LT
Posts: 10
Joined: Thu Jan 16, 2014 4:54 pm

Re: europa 2.0 last firmware needed

Postby The LT » Mon Jun 23, 2014 5:39 am

JFYI, Jeffrey has answered my email and gotten back to me with the firmware and so far, I've resolved my issue. I had a weird problem with flash memory contents being corrupted after an extended power-off and it wasn't the battery.

Got those resolved and I am happy camper now. :) Thanks for the answer, btw!

User avatar
Fuseball
Posts: 6
Joined: Sun Dec 08, 2013 11:24 pm

Re: europa 2.0 last firmware needed

Postby Fuseball » Mon Jul 07, 2014 10:41 am

Good to hear that he's been in contact with you.

I might have a similar problem with my Europa. It often fails to boot up correctly. It's not much of a problem as the only thing that gets reset on mine are the global settings. In reality that means all I usually have to set again is the MIDI channel. All my patches and presets are unaffected and I don't lose any important data.
Some noises - Bright Pylon

The LT
Posts: 10
Joined: Thu Jan 16, 2014 4:54 pm

Re: europa 2.0 last firmware needed

Postby The LT » Thu Aug 07, 2014 11:37 pm

Fuseball wrote:Good to hear that he's been in contact with you.

I might have a similar problem with my Europa. It often fails to boot up correctly. It's not much of a problem as the only thing that gets reset on mine are the global settings. In reality that means all I usually have to set again is the MIDI channel. All my patches and presets are unaffected and I don't lose any important data.


My unit had a CR2032 battery holder fitted instead of the bigger chubby 3V battery. I've desoldered the CR2032 battery and put a bigger chubby battery in. So far, I had no memory glitches.


Return to “Europa”

Who is online

Users browsing this forum: No registered users and 1 guest

cron