double triggering

The Roland Jupiter-4 and ProMars Compuphonic Analogue Synthesizer
nervousbreakdance
Posts: 3
Joined: Fri Jun 19, 2009 3:53 am

double triggering

Postby nervousbreakdance » Fri Jan 22, 2010 2:33 pm

My JP4 is prone to double triggering - every now and then a second note will play upon release of the key. This can be very annoying.

Can anyone tell me what causes this/how I can fix it?

Cheers.

Jim

Mr Arkadin
Posts: 27
Joined: Sun Jul 26, 2009 9:10 pm

Postby Mr Arkadin » Fri Jan 22, 2010 5:05 pm

Almost certainly dirty key contacts. i haven't been inside my JP-4's keyboard yet so not sure how it looks, but usually a bit of isopropyl alchohol and cotton buds do the trick.

nizzen
Posts: 2
Joined: Mon Feb 15, 2010 4:57 pm

Postby nizzen » Mon Dec 06, 2010 10:03 pm

I was wondering if anyone has a more permanent solution to this problem. I have had my Jupiter 4 keyboard repaired and cleaned by a local tech, but the problem seems to be recurring. There are kits available online, like this:

http://www.tselectronic.com/shop/produc ... ir-Kit/355

Has anyone tried this (or similar kits) to get rid of the double triggering on the JP4?

covariance
Posts: 47
Joined: Fri Oct 16, 2009 8:53 pm

Postby covariance » Tue Dec 07, 2010 10:30 pm

JP4 has got the older style bus bar type keyboard.
No rubber hence no rubber repair can help.
If only a few keys are affected then a mechanical check and clean would help.
If all the keys produce double triggering then it is an electrical problem with the keyboard scanning.

kb
Posts: 2
Joined: Mon Mar 22, 2010 2:54 pm

buss bar cleaning

Postby kb » Thu Dec 09, 2010 2:40 am

Someone on the Analog Heaven mailing list (Kevin Lightner?) posted a technique for cleaning buss bars and contacts.

It involves some disassembly, careful handling, and NevrDull metal polish.

It worked pretty well when I used it on my SonicSix and I've been meaning to use it on my JP-4 when I get the time (it also has the bad triggering...)

Good luck!

nizzen
Posts: 2
Joined: Mon Feb 15, 2010 4:57 pm

Postby nizzen » Fri Dec 10, 2010 8:31 pm

Thank you both! The problem is only with some of the keys, but it is very annoying on short release notes. The rest of the synth works perfectly after a thorough technical check up. I will have a look at the metal polish procedure- hope it's not too difficult.


Return to “Jupiter-4 [and The ProMars]”

Who is online

Users browsing this forum: No registered users and 1 guest

cron